Pages: [1]   Go Down
Author Topic: [fixed]Updating via Fast-Track  (Read 5614 times)
eHopp
Member
*

Karma: +0/-0
Offline Offline

Posts: 4


« on: February 02, 2010, 11:42:40 AM »

Not really a bug on your part but...
If a user runs Fast-Track and tries to use the update utility, it can result in unexpected behavior. Updating Fast-Track itself is fine, and updating Metasploit will at least ask you for a path. Updating anything else will tend to either cause errors such as:

Quote
Nikto
Updating Nikto...
cd: 1: can't cd to /pentest/scanners/nikto/
sh: ./nikto.pl: not found

Or it will download and install things under the hierarchy starting at /pentest rather than /pt
AirCrack-NG updates to wrong path without confirmation.

All of the following tools will update and install by Fast-Track (under the /pentest hierarchy) even though they are not installed to begin with in Matriux.
-W3AF
-SQLMap
-Milw0rm exploits
-Kismet-NewCore

I don't know if you want to change your path to /pentest to make it all integrate, or modify the Fast-Track update scripts with the proper directory path, or just warn the user about what will happen.

Another small detail, not really a bug. Much of the Metasploit documentation is in pdf format and there is no pdf reader installed by default (unless you want to use ghostscript, ugh). You might just add something like epdfview or xpdf to Matriux.
« Last Edit: March 08, 2012, 11:22:17 AM by L30 »Logged


Author Topic: [fixed]Updating via Fast-Track(Read 5614 times)
Tiger-222
Team Lead
RegMem
****

Karma: +4/-0
Offline Offline

Posts: 243



WWW
« Reply #1 on: February 02, 2010, 03:16:41 PM »

Hello eHopp !

Quote
I don't know if you want to change your path to /pentest to make it all integrate, or modify the Fast-Track update scripts with the proper directory path, or just warn the user about what will happen.
I think we will modifiy Fast-Track update script.

Quote
Another small detail, not really a bug. Much of the Metasploit documentation is in pdf format and there is no pdf reader installed by default (unless you want to use ghostscript, ugh). You might just add something like epdfview or xpdf to Matriux.
Ah yes it can be useful  Huh?

Thank you for this report, we will modify these errors for the beta2 Smiley
Logged

" owt WEE-am in-WEH-nee-am owt FAH-kee-am "

Pages: [1]   Go Up
Print
Jump to: