Matriux Community

Matriux => # howto => Topic started by: Fattenedcow on March 08, 2013, 11:04:55 AM



Title: Matriux ec-centric problems
Post by: Fattenedcow on March 08, 2013, 11:04:55 AM
So I dual booted Matriux ec-centric with windows 7 to replace Backtrack 5 r3 the other day, and I everything was running smoothly until I tried to connect to the internet. First, wicd manager asked for the root password, which I entered correctly, then it gave the error "Could not connect to wicd's D-Bus interface" But this isn't the biggest problem really. I tried to run the command "ifconfig" which should be there by default, and it said it was an unknown command. I looked around the forums, and it said nothing on how to fix this. Is this some sort of bug, or do I have to configure some stuff first? I'm pretty sure most of the networking commands if not all are not working (dhclient, ifconfig, iwconfig etc etc)


Title: Re: Matriux ec-centric problems
Post by: L30 on March 08, 2013, 12:21:25 PM
dhclient should work..

if you get an error unable to resolve /etc/resolv.conf  just do this for one time

Code:
touch /etc/resolv.conf
pretty sure that this will fix for you!

Also it would be easy to help you if you can come up with exact errors.! (although I agree that transferring of ownership failed with wicd on live cd ..it should be fixed once you install it on your harddisk)


Title: Re: Matriux ec-centric problems
Post by: Fattenedcow on March 08, 2013, 11:30:53 PM
It is the kind of error where the command isn't even recognized as a command, i'll provide the exact details in a while


Title: Re: Matriux ec-centric problems
Post by: Fattenedcow on March 11, 2013, 10:58:34 AM
I fixed this problem by reinstalling, and typing "exec wicd" in the root terminal. I have another problem though. When I try to connect to a WEP encrypted network, each time it says that it could not obtain the IP address. This is only for WEP. WPA and WPA2 and open connections allow me to connect. I heard that this was a problem with atheros wireless cards or something. That is my type of wireless card for my laptop. Advice?


Title: Re: Matriux ec-centric problems
Post by: L30 on March 11, 2013, 12:43:51 PM
Its the problem with the card you have, coz atheros ditched WEP for being outdated

this was some snippet I found somewhere, Hope this helps you

ath9k if series 9 card.. 5k for series 5
Code:
sudo ifconfig wlan0 down
sudo rmmod -f ath9k
sudo modprobe ath9k nohwcrypt=1
sudo ifconfig wlan0 up


Title: Re: Matriux ec-centric problems
Post by: Fattenedcow on March 14, 2013, 12:09:50 AM
Neither of those worked. Both times it said, "Unable to obtain IP Address"


Title: Re: Matriux ec-centric problems
Post by: L30 on April 08, 2013, 12:16:51 PM
install b43 and try